Please Help for restore Daedalus wallet

Hi , I am new to here and so please be nice :slight_smile:

On December 10, 2019, I created a wallet via INFINITO WALLET, and saved the 12-word and Master Key. After that, I did not open the wallet or take any transactions.

But when I inputed the 12-word and Master Key into the INFINITO WALLE again yesterday, I found that the ADA balances was 0$.

And i download Yoroi wallet input 12-word and Master Key again to restore my ADA wallet, but it shows Error while restoring blockchain addresses.

How should I get my ADA coins back? Have my ADA coins been stolen?

I dont think your funds have been stolen based on your description. However, it is likely that infinito is (also) hitting the issue with identifying and querying byron wallet funds. It is best to raise it with their support team - unfortunately, they do not provide support on Cardano groups/forums.

Thanks for your help.

I downloaded Daedalus Mainnet and synced all the blocks.
Then input the 12-word on Daedalus Mainnet to restore the Byron wallet, but the balance is still 0$.

Is there any other way I can solve this problem, or check if my Ada coins is still on the address or my byron wallet?


Do you have the address ?

U can check it here


Hi Alex

The address that INFINITO WALLET showed me was Ae2tdPwUPEZMtsfWq9EjeKiYBqf5JEaoavLByEpuYbGDDxUZYWAe4Pm8LiE,.

But the result returned by explorer(URL) is ADDRESS DOES NOT EXIST.

Did I make a mistake somewhere?

U are saying u have 12 seed words from infinito wallet but u tried to restore in daedalus?
U must restore your infinito wallet with those 12 seed words, not daedalus walletโ€ฆ
download the last infinitto wallet version and try to restore ur wallet;

if u have issues with ur balance after wallet restauration please contact infonito wallet support team!


OK, Many thanks Alex.

I downloaded the latest infinito wallet version and tried to restore my wallet.

But the balance is still 0$, I am going to contact the infinito wallet support team now!

1 Like