Byron wallet restored with 0 balance

October 2017 I created a Daedelus waller. December 2017 I transferred coins from exchange to that wallet. Address on exchange matches cardano explorer transaction and address in Daedelus wallet logs.
Dec 2020 I tried to open the wallet, cannot connect. Download Daedalus mainnet, import wallet with 12 word seed . Balance is 0. Install youroi, insert 12 word seed. and it reads “Unable to restore Daedalus wallet.
Error while restoring blockchain addresses.”
I contacted IOHK , who claim the seed is wrong. I think it is a bug, where the seed cannot resolve old style address and throws 0 balance. The new Daedelus does not display the address for which it claims there is 0 balance , so there is no proof the seed is for the inrorrect wallet. Any ideas? Shame to lose the coins.



When you created the wallet in 2017 you set a wallet name and spending password… do you also have them? did you tried to use the same? Are u sure it is not possible to have another seed words for another byron wallet?


I feel like this is a common issue.

Please contact IOHK Support about that case, they are able to help you if your seed is correct.


Thanks for reply, in 2017 the accent was on 12 seed code. I do not remember that wallet name or spend password were essential requirement.
My point is that the seed can be wrong or not if we can tell what address we want from the seed… Because coins are in the address. But the new mainnet wallet does not have or show old addresses.

Actually it shouldn’t, because u restore the wallet when u have issues with spending pssword… but can pe possible to have another seed words or your original one to be broken …

But listen Zyroxa and contact iohk support team.

Did you get any reply from support? I have the same problem. 99% sure my phrase is correct but it shows 0 ADA in the wallet.

Hi bendik, support keeps saying I have the wrong seed. Here is my latest reply to them:
"Hi Mei,

thanks for talking to me. Please understand what I am saying. You talking about the wallet I am talking about the address. The coins are in the address. The new wallet does not display what address it refers to when reading 0 balance. To prove that my seed is wrong I need to see the address it points to and compare it to my address in the old wallet and Cardano explorer.

My point is that mainnet has a problem and in this case and maybe others, the seed cannot resolve old addresses and therefore shows 0 balance. Yaroi is saying “cannot retrieve address”.

Thank you,

I’m in contact with support as well. Feels like its something wrong with restoring the old Byron wallets. They told me my seed is wrong or belongs to a wallet without ADA, but Im 99% sure its right seed and I only made one wallet.
Hopefully we will get some help. Let me now if you solve the problem.

But it’s remaining 1% chance to be true… could be possible to have another seed words stored somewhere ?


Cant find any other seed. Will try to look more.
But if the seed is wrong, why does Deadalus make a wallet?

good question, when you tried to restore, did u used the same wallet name and password? or did u set new wallet name and new password

Maybe same name, but probaly new name and password.

do you remember the old name and password? can u try to restore with them?

Dont think so. I will try again and see.
Is it possible to find my adress in the old Daedalus files?

Wow thats awsome!
Now I just have to remember the spending password.

I set up my daedelus in late 2018 transfer ada into it , left it until now , downloaded the new version of daedelus and tried to transfer my ada ( byron ) but says zero balance , i have the 12 phase words and in order but i cannot remember spending name or password is there any help out there ?


Did u tried to restore ur wallet as byron in daedalus?

Check the steps


I know the issue.

With the new shelley wallets they have masked or hidden or deleted old byron wallet addresses to prevent people from using the old ecosystem in the wallet.

Ultimately that must have messed with the way the wallet retrieves and registers information from the blockchain that ultimately uses the old addresses. Meaning we have a zero balance because the wallet is not properly retrieving old balance.

They have even removed the receive option from the byron wallets as evidence of this.

They know this, but will keep stalling because they probably haven’t found a solution to this. They will rather claim you have the wrong recovery phrase, which as we know if entered wrongly in most cases will not retrieve any wallet data.

Most of us only had one wallet anyways and thus would have only kept one recovery phrase.


Thank you for your message of understanding. Standard corporate politics of greed, do not admit or say anything that will adversely affect the price.