Problem after Daedalus 4.04 Update

I updated from Daedalus 4.03 to 4.04. Upon launching 4.04 for the first time, it appeared to start working but “crash” shortly after launch. If I try to launch it now, I get a Windows error dialogue box for “cardano-launcher.exe” that states the following:

“C:\Program Files\Daedalus Mainnet\Daedalus Mainnet.exe: createProcess: does not exist (No such file or directory)”

Any suggestions what I should do to try to resolve this or what happened?


Do u have enough memory?
U can try to uninstall/reinstall the daedalus if u have the seed words for the wallet

Also same issue


It’s a bit different because it only crashed once, then will not even attempt to load/run and gives the aforementioned error dialogue. I do have enough RAM. Will try a reboot and then if no other suggestions, I do have seed words so could try the uninstall/reinstall.

1 Like

Update: Uninstall and re-install worked just fine. IDK what happened to be honest. My theory is that when I first attempted to update, my kids distracted me away from my PC and I wasn’t there to click “Yes” to allow the program/installation to make changes and it timed out/messed things up. Anyway, this one may forever be a mystery, but it worked to uninstall/re-install 4.0.4 from “scratch”.

1 Like

Mine has also crashed as well - just when I needed to use it as well :face_with_raised_eyebrow:

As an update I notice that if you just leave the wallet long enough when it says it has crashed then it will re sync and open up after a while

Nope. Having a problem with 4.04 update. The node crashed a couple times on the 4.03 but came right after a reinstall. But now the 4.04 update won’t load at all. Gets stuck at ‘Verifying the blockchain (99.9% complete)’ with Cardano node not responding and not syncing. When I stop Cardano node and try again, either the same thing happens or the node crashes entirely. I’ve uninstalled and reinstalled 5 times, cleared the cache and restarted the computer. Downloaded from Brave and Chrome. Same thing happens. haven’t had the problem be so persistent before. Wouldn’t be so bad if I didn’t have a time-sensitive purchase to make. Would even love to reinstall an older version if I wasn’t blocked and prompted to update.

Try to leave it for 1-2 hours. It fixed for me automatically.

Thank you. You know what’s weird. I just tried to reinstall a previous version (3.3) and for some reason the node restarted at 99.6%, and the wallet now opens, first time since the update over 12 hours ago.

I’ve had the same problem with with 4.04 update. I am stuck on 99.3% with error messages saying the node is not responding and not syncing. After trying to restart it multiple times I left it running instead and it seemed to solve itself by letting it run for something between 30-90 min in my case.

1 Like

Hello adaman1
I have the same problem with my daedalus wallet and get the same windows error box. I cant start my wallet :frowning:
What have you done to uninstall the program? Used the uninstall.exe under C:\Program Files\Daedalus Mainnet? And then download und install the new wallet from
Or other ways?

Thanks for your information.
Greetings from Austria

Before to uninstall check if u have the seed words because u will need to restore the wallet

U can follow this procedure

Then install the new version 4.0.5

Thank you for your prompt information :slight_smile:
I have unstalled und installed the wallet - everything ok!
But now i see my wallet without entering my seed words … ??? There was no recovery-point?
I see my ada coins und my transactions - everything like before uninstallation.
How is this possible? Without the seed words?

Perhaps u didn’t removed all files
Usually after uninstall/install process u need to retore the wallet… as far as I know