Re: Expect a Different Error when delegating with Ledger Nano X

I setup Yoroi Wallet connected with Ledger Nano S first. Recently I bought a Ledger Nano X and I paired the new Ledger Nano X with the old Ledger Nano S

The new Ledger Nano X has all the access that the old Ledger Nano S has

I try to re-delegate my ADA in Yoroi Wallet with my Ledger Nano X, I made sure I selected the option to delegate with Ledger Nano X and not Leger Nano S. When I try to re-delegate with Ledger Nano X, it displays an error expecting a different device.

How do I re-delegate with my new Ledger Nano X instead of the old Ledger Nano S without causing the “expecting a different device” error?

As far as I know, Yoroi remembers the specific hardware device and you have to delete the wallet and import it anew, selecting the new Nano X when pairing.

So just delete the existing Yoroi wallet, then import a new Yoroi wallet and follow the steps given by Ledger in the following article to connect Ledger Nano X and Yoroi

Then I will be able to re-delegate with my Ledger Nano X. Am I correct?

1 Like

Yes. Should work.

Okay, thanks a lot

When I created my Cardano account in Ledger Live, I noticed the total ADA amount displayed does not include Rewards amount

Do I need to withdraw ADA rewards within Yoroi wallet in order for the ADA reward amount to also show up in my Cardano account within Ledger Live?

Ledger Live does not implement delegation and rewards (and native tokens) up to now.

Yep, you could do that.

Personally, I would ignore Ledger Live until the most basic functionalities of Cardano are there.

And I would also use another wallet app. Most alternatives do not need to waste transaction fees for withdrawing rewards, but just do it in normal transactions automatically.

What is the difference between the fee charged for withdrawing rewards and a normal transaction fee?

Withdraw rewards within Yoroi cost transaction fees, Which other wallet apps does not waste transaction fees for withdrawing rewards? Which wallet app would you suggest?

Transactions that you would have done anyway can use rewards as an additional input. That way you only pay a few additional bytes in that transaction instead of a whole additional withdraw transaction as Yoroi does it.

Daedalus does not even have a button for reward withdrawal and just does it automatically from time to time. offers three possibilities: An explicit button for doing an extra transaction like Yoroi, a setting to do it automatically if it sees fit like Daedalus, and a checkbox on every transaction to force withdrawal with that transaction.

It’s also important to consider that rewards also contribute to your stake, before they are withdrawn. So, there is no need to withdraw them, unless you are really short on ADA.


I don’t think I will withdraw rewards since it contributes to my stake

Since you can transfer ADA without un-staking them, there is really no point to withdraw rewards or un-stake. As long as the wallet is stake the ADA within that wallet is staked

Well, for yoroi the rewards can’t be spent; must be moved from stake address to payment address in order to use them

BTW… ada is now added to ledger live :slight_smile: u can test it


So the correct way to spend rewards is to first withdraw rewards from inside Yoroi wallet, then it can be moved to an exchange or some other place to spend. Is that what you are saying?

Exactly, if you will not withdraw the rewards u will not be able to send out of the wallet

…, which – again – is a limitation of Yoroi. Other wallet apps can do it perfectly well.

…, but Ledger Live cannot handle delegations, rewards, or native tokens up to now.

I am Having this same issue. I deleted my Yoroi extension and followed instructions from Ledger on set-up of new Yoroi wallet, as well as staking instructions, but I still get an error message when trying to delegate.

And my Cardano app and firmware on Nano X is up to date

Is there a way to change the device preference from Ledger Nano S to Ledger Nano X?
I am still using Ledger Nano S to delegate. I have tried using Ledger Nano X to delegate but it gives an error

I believe staking is not active yet from ledger live


Tanks for replying. I did not have Ledger Live up when I connected my Yoroi wallet, per instructions on Ledger webpage.

try to connect your ledger on
do you see the right balance? if yes, you can delegate and perform transactions from there… perhaps yoroi has few issues atm … you can contact also yoroi support team via app (yoroi) support section

Thank you for the info. Contacting Ledger support is not very straightforward. I am looking into the Adalite wallet.