Resolve issues with the pool registration

Hey folks,

there are few steps which help to verify if your registration is alright and if not helps to debug the issue! I learned this on try and error and by following the official Cardano Telegram channel.

  1. Check the hash number of your published metadata.json
    cardano-cli stake-pool metadata-hash --pool-metadata-file <(curl -s -L
    cardano-cli stake-pool metadata-hash --pool-metadata-file <(cat poolMetaData.json)
    Replace the URL and the poolMetaData.json as it fits your setup.
  2. If the hash number is the same, chek if your metadata is represented correctly with
    cardano-cli query ledger-state --mainnet --allegra-era --out-file ledger.json
    This operation is memory hungry and will show if your hardware is good enough to run a stake pool. Short term it helps to include a swapfile on your node to resolve memory issues.
    Now look through the file ledger.json and search your hash number.
  3. Sometimes Daedalus is slow in showing your pool ticker. This can be resolved by deleting the file cardano-node.socket when the application Daedalus is not running.
    How to find this file: click on Help in your Daedalus application, then click on OPEN next to Daedalus state directory:. Next open the directory wallet. Here you can find the file cardano-node.socket and delete it after the Daedalus application is turned off. Restart your Daedalus. Now it should fetch your pool ticker. This process takes some time.
  4. If you still experience problems I learned that it helps to register the pool with a new metadata.json name. For example you might consider to give your metadata.json file a version number: metadata1.json.

Johann ADAholycs


Hello Johann,

Thanks for showing me this post. When I attempt to follow the different steps I get stuck on multiple parts.

Step 1
The first command runs just fine and returns me a hash. When I run the second command with the name changed to “poolmeta.json”, it returns the following: poolmeta.json: No such file or directory

Weird, since when I look the file up with Filezilla I am able to find it. Pooltool no longer shows me the hash mismatch message so I took the liberty to attempt step 2.

Step 2
When I submit the command I get the following:
Shelley command failed: query ledger-state Error: Error while looking up environment variable: CARDANO_NODE_SOCKET_PATH Error: "CARDANO_NODE_SOCKET_PATH"

I tried to find answers to this problem, but the answers listed in the old threads don’t seem to work for me.

Any ideas what might be wrong or how to fix it? Help is much appreciated!


can you invoke just that command line:
cat poolmeta.json
you have to provide the correct absolute or relative path to your file.

Alright in the second step one should update it to the mary-era (We had no hard fork, yet), but I believe your cardano version is laready 1.25.1:
cardano-cli query ledger-state --mainnet --mary-era --out-file ledger.json

Probably in your case the command line
shows empty.
you can export
export CARDANO_NODE_SOCKET_PATH=/path/to/your/.../db/socket
This should resolve the issue!

I am off until tomorrow good luck!


The second command for the hash seems to work now. Thanks! Both hashes are the exact same and are showing on adapools and pooltool now (Daedalus is missing still, might take two epochs?)

This cardano-cli query ledger-state --mainnet --mary-era --out-file ledger.json for some reason returns cardano-cli: Network.Socket.connect: <socket: 11>: does not exist.

When I point export CARDANO_NODE_SOCKET_PATH=/path/to/your/.../db/socket to my /db I don’t see a socket folder within. I do see one in /opt/cardano/cnode/sockets called “node0.socket”. Could I point to this one?

Thanks for the help. Have a great day!


yes that’s how the cntools people do it their way. Unfortunately I have never used this tool, might try on testnet someday, but I am happy with my own scripts.

node0.socket sounds correct! I bet you tried it already.
Ok good news. If Daedalus still making problems then the last point in my list of troubleshooting should help. Good luck!


1 Like

Thanks for all the help! The pool is now listed in Daedalus, PoolTool, and AdaPools :slight_smile: I couldn’t be more happy :smiley:

1 Like

Don’t run manually the scripts if u have cntools :slight_smile: u have all u need in cntools. just run ./ from scripts folder and enjoy it!


1 Like

EDIT: Just when I wrote this post all seemed to work again lol. Guess I was impatient.

After running for several months (and updating multiple times) the node0.socket seems to be gone. This file has been a pain in the butt lol. I had to use the export solution as described in this thread multiple times and also checked the env file multiple times.

This time the node0.socket just seems to be gone. I have restarted the node and waited 15 minutes for the service to make a new node0.socket. However, when I do

sudo systemctl status cnode.service

I keep getting the following response

WARN: A prior running Cardano node was not cleanly shutdown, socket file still exists. Cleaning up.

Well, I can’t find a socket file on the server. Are there steps/ solutions I can take to force a new socket file?

this is normal, the node is up and running?

1 Like

The node is up and running now. It took a while for all nodes to sync and see each other again but all seems good :slight_smile: