Restored Wallet Showing 0 ADA

I’ve been using Daedalus for a few years, and earlier this year I restored my Byron wallet to a Shelley wallet and the transfer went fine, but the computer I made that transfer on (which is only 4gb) can no longer handle Daedalus so I tried to restore that wallet onto a newer computer last night but my balance now shows up as 0 ADA. I tried a second time and even tried to restore it to a Yoroi wallet and I’m still getting 0 (there are 0 transactions - both computers bought new from manufacturer and only ever used to download and run Daedalus). Any help as to what I’m doing wrong? Should I try restoring it from my original Byron phrase?
Any help would be greatly appreciated,

Just an FYI the old 4gb computer worked fine with Daedalus until it required me to update my version of Daedalus – I haven’t been able to access my wallet on that computer since.

It means u are using the wrong seed words or perhaps u have a ledger/trezor

Hey Alex - I don’t have a hard wallet. At least not one associated with my ADA.
I know the seed words are correct, but would trying to restore from Byron seed get me to the same place? I appreciate it.

If u moved the funds from byron to shelley… then the funds should be on shelley wallet (24 seed words)

PS: check also the ledger/trezor… who knows… maybe are there… just pair the ledger/trezor on daedalus or