Restored yoroi wallet & now ADA balance is zero

Hello, I need help getting my ada back. So the yoroi wallet app on my iPhone was acting glitchy so i decided to uninstall the app, and then i reinstalled it and now my ada balance is zero and transactions is also zero. I don’t know what to do or how to fix this issue. I tried restoring the wallet on google chrome yoroi extension app and the wallet still shows a zero balance. I am 100% sure my 15 word phrase and spending password are both correct.

Is anyone else having this issue? or does anyone know how to fix this issue? I am very worried!

thank you very much in advance for help and comments

1 Like

Hey @Tz888

Did you choose to restore a shelley wallet instead of byron wallet?


1 Like

First of all, no need to be worried. If your seed phrase is indeed correct, then your funds are safe.
For restoring the wallet you only need the seed, the password has no relevance as you have set a new one (but you can if course choose the same pw as your old one).
After typing in the phrase double check that it is typed in correctly, some words can be very similar.
Lastly, when I tried out the yoroi Firefox extension it did take same time to show the correct balance for some reason.

1 Like

Thank you for the reply Fabian!

Yes I have tried to restore both a shelley wallet and byron wallet and they both show a zero wallet. I also tried going to and also checked it through the fastest method using my mnemonic phrase and that also pulls up a zero balance. Do you recommend I try anything else?

1 Like

Well that sounds incorrect to me.

As far as i know you should be able to restore your wallets in adalite, Shelley and Byron wallets.

Imo id open a ticket at : and ask there for help.


1 Like

Hi thanks for your reply! I used the chrome extension but I will try the yoroi Firefox extension and hopefully I will get a correct balance there.

How long did it take for you to see a correct balance? I am worried because it has already been about 24 hours and still I am getting a zero balance.

1 Like

It didn’t take that long. But I’ve seen another thread in the forum with someone having a similar issue. Apparently Yoroi wasn’t syncing for some reason.

You could also try using Daedalus, but downloading and synching the blockchain will take some time initially.

Also as Rob mentioned check if you chose to restore the correct wallet. If you haven’t actively done that in the last weeks then you probably still have a Byron era wallet. You’ll have to restore the Byron wallet and then transfer your funds to a new Shelley wallet.

I don’t have any links on me now, but you’ll find more detailed information if necessary in this forum or the Cardano subreddit.

1 Like

I’m experiencing the same problem. Didn’t forget my 15 words, but every wallet I check for it I get 0 balance. I can even SEE the 57601 ITN rewards ADA sitting there but the phrase words aren’t connected with it or something. I did mess around with Yoroi trying to redeem the ITN rewards so maybe it’s in a Yoroi wallet.

This whole “as long as you have your keywords nothing can go wrong” mantra isn’t working for me. Everything was so slow and uncooperative back in Dec. and Jan. something got outta whack, partially my fault I’m sure, but I tried…

I feel it’s not anything we did on our end. How could I lose all my ADA just from deleting the Yoroi wallet app from my iPhone? I should be able to restore with my 15 words. I know they are correct because I have them written down and I have used them before and restored successfully.

I have been reading old posts from May of last year about people not being able to see their correct balance due to the Yoroi server not synching correctly. I’m hoping it’s just that again and it can be fixed on their end. I opened a ticket and asked for help so lets hope they have a solution.

Because you’re testing your 15 words after a while perhaps, causing one or more of the words to either be switched in order, or be read differently (eg: derive/drive, blue/glue, etc).

That would only apply if you’re not able to verify your balance (or atleast ANY transactions) in . If you’re not able to see the balance there too, it indicates a problem with mnemonics.

Did your funds show up?

I’m my experience if you give it time, your funds will show up as long as you have :

1. Created a new Shelly Wallet. 
2. Put in the correct pass phrase words. 
3. Restored your Byron wallet and sent the funds to your new Shelley wallet. (It will automatically pick your new Shelley wallet.   

You will end up with one Shelley wallet ( new) and one restored Byron wallet (old).

If you create multiple new Shelley wallets, the wallets will show the funds in all the wallets…

Just delete any extra wallets…

You should be all set… let me know if you get stuck somewhere…

1 Like

Are you talking about claiming your ITN rewards?

No it’s my ADA

My ada balance is also showing zero on adalite. But I know I’m entering my phrase correctly because I have intentionally misspelled or skipped a word and when I do that it generates an error and doesn’t even let me go further until I enter the correct word.

After you built your wallet, your New Shelley wallet, you must go back and restore your old Byron wallet with the same phrase, and it will show your funds and request to send them to the new Shelley wallet, please refer to my above post and make sure you do step 3. That is when you will see your money.

Let me know if this helps…

I used my phrase to restore a Byron wallet and when that showed a zero balance I restored a Shelly Wallet using the same phrase and that wallet also shows a zero ada balance.

What did you mean by you can see your ITN Ada sitting there? Are you sure your not using the seed from the ITN rewards wallet? Cause that’s a different seed.

If you haven’t migrated your funds from Byron to shelley wallet it’s normal that you don’t see any balance when restoring a shelley wallet with a Byron seed. But this does not explain why you don’t see your balance in the Byron wallet.
Could you please explain step by step what you did, starting the first time you created your old Byron wallet?

That doesnt mean much, there are gazillion valid combinations for a wallet, and just changing a word randomly may not work (due to checksum mismatch) but changing it to one where checksum matches will land you up on empty transactions page.

Empty transactions in ADALite as well as Yoroi is enough proof that you’re mnemonics being used are not the same as what you were using before

So I finally figured out how to get my wallet with all my ADA. I had my ADA connected to a ledger device so I didn’t need to restore using my 15 word recovery phrase. I used the Yoroi Chrome extension and restored using my ledger hardware wallet. What a relief !!

Thanks to everyone that replied to my post and tried to help! I’m really grateful for the support I have received from this forum.

1 Like