Restoring Yoroi Wallet on new computer

I got a new computer and tried restoring my Yoroi Wallet on my browser extension with the 15 word passphrase, but my funds are not there! I was staking on the Mantis Pool and have a telegram bot that has been confirming my rewards.

How do I restore my wallet that was connected to this Mantis Pool to see my balance and rewards?
Please help!!


Do u still have yoroi installed on your old laptop/desktop?


No I wiped the old computer clean to sell…


In yoroi u need to go to add wallet SHELLEY era and restore… use your 15 phrase words… set the name and spending password for the wallet and u should see your funds there

Be carefull to write exactly the same words! Maybe u tiped something wrong

Do u see any transaction in history?


Yes I did all that and there is no transaction history and the address is different than what I used for the telegram bot to identify my rewards with the Mantis Pool.

Is there a way to restore with my wallet address? I don’t know how I could’ve gotten the wrong words.

What address did u had before?

Check both in

You want me to paste my address here? Is that safe?

Is just an adress… but anyway I tried to check mine and it doesn’t work

Strange… it should work… are u using hw wallet? Or just yoroi

Just Yoroi.

And it is the first time when you try to restore since you created?

Yes. It’s been a couple months since I opened by Yoroi wallet, but I figured it was all good since I have been getting telegram updates on my rewards.

Then maybe… I don’t know maybe u tiped one word wrong… or maybe you wrote them in another order… try to think… or maybe it is a sync issue

Yes, it seems impossible to get the words wrong because it makes you double check after writing it down. The thing is the address is different…I really hope I didn’t lose my funds!!

You mean the receiver address?

Could be a sync issue


Another question… did u downloaded chrome mainnet?

No I did not.

You know, you can try to recover your wallet also on adalite

Thanks Alex for all your help!
I tried the AdaLite wallet too, but I still get a zero balance. I must have somehow gotten the wrong passcode and I guess I just lost 15000 ADA…damn!


Relax, ADA will be there waiting for you… try to put things in order think what you did wrong… maybe you wrote the words in other order (when you wrote them on paper) … or maybe u have other 15 words somewhere… you need to relax and think…

I am sure you will recover them… if I can help you I will do it, just ask


I appreciate your attitude!
Praying for some solution. I wish there was a way to restore my wallet from the address…

Your ADA are safe, but somehow you need to see what is wrong with that phrase, why it’s not working… perhaps you have another security phrase somewhere else… perhaps you wrote a word wrong… perhaps you wrote them from right to left when you bkped them;

I am sure you will recover ur ADA;