Shelley Mainnet Daedelus Wallet not connecting to network

I have just installed Daedelus 2.0 mainnet and it is stuck in the opening screen with no syncing. It shows all the menu bar items though so is not the known issue.

Connected: No
Synced: No
Cardano Node State: Running
Cardano Node responfing: No

I’ve tried restarting Daedelus and restarting the node - any other ideas? This is an upgrade from the Byron Mainnet.

I’ve just installed the ‘Flight’ version and it connects and is syncing…


Hello and welcome @Kent_Perry,
how long did you wait? Sometimes it just needs a few more minutes.

Depending on your operating system you can press “command + d” on Mac or (I believe) “crtl + d” on Windows for more details.


Been waiting 20mins now and still nothing. This is on Windows… any shortcuts for that? :slight_smile:

Ctrl-D :grinning:

1 Like

Ah, that just brings up the status page(I usually just click the icons) - that’s how I know it’s not connecting :slight_smile:

Are you running the ‘Flight’ Version along side Daedalus 2.0?

Yes, but only just installed flight to see if it would connect - it does…

I would suggest removing the Flight version and reinstalling Daedalus 2.0. Make sure to have your recovery phrase for any wallets you currently have etc.

If it still does not connect please submit your problem to the help desk

It is now still saying not connected but is ‘verifying the blockchain’ -whatever that means?

That looks good. (assuming the percent numbers are increasing)

Before the first start the new wallet will verify every single block again from the very first one.

1 Like

So all looks good now - Daedelus started and is now syncing the wallet - didn’t do anything…!

1 Like

Same thing happened to me. I’m on a Mac. Earlier today I could connect easily enough. Seems that you just have to wait.

ive also experienced same thing, it worked fine when i first installed it, and when i restarted it after a few hours its stuck on the “conneting to netowrk” screen, i have no other versions of daedalus installed

ive also experienced same thing, “connecting to network” screen, i have no other versions of daedalus installed