Tesnet Wallet Stuck On Connecting

Incentivized Testnet Wallet stuck on “Connecting to network”

I’ve tried:

  • Uninstalling Daedalus then delete Daedalus folder in /AppData/Roaming/ then reinstalling Daedalus
  • Ensure machine clock is synchronized with Cardano testnet
  • Running Daedalus in Administrator Mode
  • Ensured no other service on computer using port 8090
  • Disabled ALL firewalls in case that may have been interfering
  • Deleted open.lock file in /AppData/Roaming/
  • Flushed DNS Cache
  • Rebooted my router
  • Etc…, etc…, etc…

Nothing worked…

I checked Daedalus’s node.log file and the only thing I could find indicating any errors was this line:

CallStack (from HasCallStack):
error, called at libraries/binary/src/Data/Binary/Get.hs:351:5 in binary-

At present most likely cause by far is network congestion, just keep restarting, but be patient, leave a while between tries, not a major disaster if you lose a day or two’s rewards.

Everything is working now, staked my ADA <3

I had the same issue (Win10pro) - i could solve it by reinstalling testnet daedalus (i also deleted the Daedalus - Rewards v1 folder in > APPData > Roaming) - works fine now :grinning: :+1: