Trezor&Yoroi "staking rights do not match"

I can smell people like you :))) it’s very hot in your country :))

1 Like

Can u change the name, u have been exposed :))

I have it on yoroi app same problem

1 Like

Alexd1985, no I havn’t succesfully signed a transacation with my trezor. I created a trezor wallet on yoroi, and sent my ada to it. I’ve also since plugged my trezor into another computer and downloaed yoroi wallet on it. The trezor on my second computer shows a different public key in yoroi than the original account that’s got my 1,000 ADA in it on my first computer which i can’t sign transaction for, or i get the “staking rights do not match” error.

[quote=“aaronfitz, post:31, topic:79313”]
. I created a trezor wallet on yoroi

I’ve been using YOROI for a long time…
How do you… “…create a Trezor Wallet
On YOROI…” ?

Then perhaps u used a random/auto generated passphrase?

Greggybone. I initilized my trezor with the trezor suite app. I loaded the yoroi browser wallet. I selected connect to trezor hardware wallet. I sent my ADA to my wallet address in the receive tab. Now the ADA balance on my “my trezor wallet” in the yoroi app is shown in my wallet, but I can’t transact it. If I try to send it, the trezor says “Change address staking rights do not match the current account.”

Alexd1985. How would I have used a random/auto generated passphrase. If I did use a passphrase when I set up my yoroi wallet, there’s only two different words I would’ve used as the passphrase. I tried them both with the passphrase enabled in my trezor settings, it resulted in the same error.

Do you think it’s possible that because my trezor has a 12 word seed phrase, that I’ve accidentally created a “read only” wallet, that I can’t import or access, if I did in fact add a passphrase to it?

dudeee i am having same problem , starting to get really frustrated lol

please can we figure this out. ive takin all steps necessary i just can not send

did u connected the trezor on how is the balance?

My trezor shows a 0 balance when connected to adalite, daedalus, or when loaded onto yoroi on my other laptop. The only place my balance shows is on the yoroi wallet that I initially setup with my trezor, called “my trezor” wallet, but that I can’t transact that wallet because I get the “staking rights does not match error” on my trezor screen when i try to “sign” any transaction for that wallet with my trezor

check to deactivate the passphrase from trezor settings and restore again on

deactivating the passphrase and connecting to adalite shows my trezor has a zero balance

I’m going to leave this trezor in the state that it’s in, and lock it away with a document that explains that it may have 1000 ada on it, on a “hidden,” or password account. Hopefully we can figure out why I’m not the only one with this problem. In the mean time I’m going to get a new trezor to transfer the rest of my crypto, and only a small token amount, before I ensure I set it up correctly. I must’ve made a mistake?

@aaronfitz Did you ever import your recovery phrase into Yoroi?

The Trezor has a bug in the way that it generates Cardano wallets and keys. Your Trezor phrase can only access the same wallet & addresses when it is imported into another Trezor, or the Trezor emulator. You can’t import the recovery phrase into Daedalus/Yoroi/Adalite, or even on a Ledger hardware wallet (Ledger has a different bug).

See: Cardano key derivation deviates on 24-word mnemonic · Issue #1387 · trezor/trezor-firmware · GitHub

If the above info does not solve the problem, then let me know, there are some other things you can try.

My trezor has a 12 word seed phrase in it. I’ve tried to import it into Yoroi, adalite, and dadelus. The result is a wallet with a different key, and a zero balance. I’m thinking that I may have used a password like AlexD suggests, and created a “12+1 seed phrase,” or hidden account, on my Trezor. However, there is only one password that I would’ve used for this, and when I try to enter it to sign a transaction I get the same error. Also, if I try to open a new wallet connection on Yoroi with entry of this password, I get a zero balance wallet. The only place my balance shows is on the original wallet shown in Yoroi that I initially created with my trezor, that I cant transact. I don’t know how to recreate the initial wallet that has a balance in it, my trezor is acting like it doesn’t want to reproduce the public keys for that wallet, and it doesn’t know what the private key is either.

If the problem is with your 12 word recovery phrase having one or more wrong words, you can try my open source recovery software: GitHub - fixmycrypto/FixMyCrypto

It doesn’t have passphrase (extra word) brute forcing yet (coming soon), but if your passphrase is correct it will fix any mistakes in the 12 recovery words, and it does support the unique private key mode needed for Trezor-derived Cardano addresses. (Which as I mentioned above are different from Daedalus/Yoroi/Adalite/Ledger addresses derived from the same recovery phrase.)

Thanks. My 12 words phrase isn’t the problem because I wrote it down, and confirmed it was correct with a simulated recovery on the trezor. If I used the extra word, there is only one word I would’ve used. It doesn’t work. Do you have any other ideas. Thanks

Try to enable the passphrase and don’t write anything when it will ask for the passphrase… did u tried to restore the trezor using the12 seed words?

Please be aware that Marceliono’s message above is a scam and they will try to steal your tokens.