Updated a relay to 1.23.0. Getting EKGView error. Any workaround or is this a bug?

Updated a relay to 1.23.0 and tried to load EKGView. I get this error.

[cardano.#ekgview.realizeFrom:Error:5] [2020-11-29 15:38:55.98 UTC] EKGView backend disabled due to initialisation error: EKGServerStartupError “Network.Socket.bind: resource busy (Address already in use)”

There does not seem* to be any other issues present. Is this a bug or is there a workaround for this that anyone has encountered or is aware of?

Is there a cardano-node process left? hiding somewhere… blocking the port? (sudo ps -A | grep node) Just wondering… I have no experience with EKGview though

Check this

Thanks for the reply. The relay is the only node running on this server. All relays and bpn are all in their own servers. I tried a server restart to see if that would clear out any other running processes but no joy.

Yeah; I don’t use ekg; I’m using grafana + prometheus for monitoring… and no problems after upgrade.

I use grafana + prometheus as well, no issues before this update. grafana is still working fine. I still like using the EKG as it’s faster to see what’s going on when all ready logged into terminal.

I do see prometheus and cardano node both running, those are the only two things that pop up.

Update: EKGview apparently has been discontinued. The error I got was because it was counting the Cardano-node when checking. Running pkill cardano-node then trying to start EKG got it started without errors BUT still only text view. The interface is apparently no longer available and gLiveView should now be used moving forward. EKG was left out of the 1.23.0 update.

New issue, when trying to start gLiveView I get an error
[Node socket not set in env file and automatic detection failed! [source: gLiveView.sh]
This should be detected automatically so will play around with this some more and if I find a resolution I’ll be sure to share it for posterity.

I had few issues with env file but I modified and now is ok :slight_smile: check the port,path, etc

I want to clarify because I believe I mis spoke in my previous comment and want to clarify for anyone else that may come across this. EKG is still present and running. LiveView is discontinued, gLiveView is it’s successor.

Looking over the env to see what adjustments I can make, it seems like every change I make another issue arises :).

1 Like

Just needed to update where the CNODE_HOME was pointing, everything clicked on from there. All is good.

Great! I’m glade you solved it!

1 Like

Hey guys, so I am receiving that same error and was wondering how I may go about resolving updating where CNODE_HOME is… I keep trying to run my relay and it will quit after a few minutes.
Any help would be appreciated


Are u using cntools?
What error do u receive?
What version are u running?
Your node is full sync?


Hey Alex,
cardano-node 1.24.2 - linux-x86_64 - ghc-8.10
I used docs.cardano to start up the node, so not cntools.
I received that same EKGView error when starting up.
I’m synced to ~4,752,000 blocks

Ok, wait to sync first and check again after;
do u have env file also? Nano env and edit your right path where CNODE HOME pointing (and activate it by deleting #)



I’ll keep trying to sync this guy… it has been a pain in the butt with it stopping every few minutes

For my setup I needed to update these values.

CONFIG I needed to change the name of the config.json to match
SOCKET="${CNODE_HOME}/db/socket" (node0.socket did not work)
TOPOLOGY I needed to change the name of the topo.json to match

Other than that I left it stock with no changes.

This gets ./gLiveView.sh to run for me.

If your node keeps stopping every few minutes you may have another issue. What resources are you allocating? I was having issues with nodes dying when running 2 cores and 4 gigs of ram. Upped to 4 core and 6 gigs an everything seems to run much smoother. Should note, the node issues started after the Allegra update.

It happened when I was trying figure out my topology files… would it be easier for a newb like me to just redownload everything using cntools?

So I went to check on /usr/bin/env and the entire file looked like this…


Is there another env file that I am missing?
Thanks for the help.

Also went up to 4core and 5 gigs