Wallet constantly "connecting to network"

daedalus

#1

D. Wallet on Apple Mac has always worked perfectly, but today it is stuck at “connecting to network…” have tried restarting a couple of times.

Is my version good? I’m not sure what version I am on, because About says 0.8.2 but the title bar on the window says 1.0.3619.


#2

The later version number will be the correct one, I’d guess, but anyway that’s not the issue, this is a common problem – try searching the forum for “connecting”.

This is from the Daedalus FAQ:

My screen is stuck at “Connecting to network” after updating the wallet

This is because some of the files are missing due to the update. In order to fix this issue, you’ll need to reinstall the application.

https://daedaluswallet.io/faq/


#3

Did you recently update your Mac OS? I did yesterday and had this issue. In fact each time I have updated the the OS I have had to do the following. Daedalus not launching: disconnect from internet and relaunch. OK now it is launching and stuck on connecting to network. Shutdown Daedalus. I use Lil Snitch as a firewall, so I delete the firewall rules I have for Cardano and relaunch. Now everything is fine. Daedalus works as expected from now on. The wallet is finicky. I don’t know why this method works for me but has solved my problems after each OS update.


#4

Nope, no updates. I went to download a newer version and I am on the latest already. hmmm.


#5

regsanman you literally just went in to Lil Snitch and deleted the rules manually? possible this is occurring to me as well because I just installed the latest security update from apple and i also use lil snitch. After upgrading Mac OS I am unable to open the Daedalus Wallet.


#6

I went to Lil Snitch Configuration and scrolled down to “Cardano-Node” . There are 3 rules there allowing connections. I think I just unchecked them instead of deleting. Same difference though, Then upon relaunch Lil Snitch presented dialogues asking for permissions, recreating the rules. I may have my Lil Snitch set to a more manual mode.


#7

Amazed they have issues. Totally pedestrian. They have like 100 million USD or something, can’t they just hire a contractor for 6 months to sort these kind of trivial problems out?


#8

check out today’s weekly technical report . They are fixing the issues.


#10

I closed all apps, restarted mac, immediately opened wallet - worked.


#11

It looks good, I’ll give it that. I think there is some kind of background process that makes the wallet work and possibly if that crashes for whatever reason, then it does the “connecting forever” thing.


#12

I ended up finding a resolution to my issues with the Cardano wallet “connecting” forever.

If anyone else is experiencing this issue on a mac, check out my response to the Cardano team’s post here: IOHK statement: connecting to network issue


#13

For this issue, they might be having maintenance or something… since they only got few nodes this might be a common issue in this Byron stage. Maybe if we’re running Shelley, issues like this will be a thing of the past…


#14

As far as I’m aware there’s no reason to believe that’s an issue.


#15

ok, thanks for the correction. Normals apps that’s the usual excuse.