Where are my rewards?

Well, I had my ADA staked since yesterday at 10:30 am in Daedalus in the first most recommended stake pool, D360, and then it came up as an unknown stake pool soon after that yesterday but it said I was still delegated. So when the epoch was over today I received no rewards and the stake pool still is apparently unknown. What is going on?!
Can someone from IOHK answer this question?

I just lost all stake pools at epoch 5.
Says I’m delegated to an unknown pool??
Started staking in epoch 3

1 Like

Pretty sure you’re not due to receive rewards until next epoch.

Yes, I lost all stake pool listings as well…

Do you know why it’s saying unknown stake pool and all stake pool listings are gone?

No but people who have seen that are saying it fixed itself later.

So I should receive rewards for the present epoch happening now and the wallet issue could correct itself.
OK, thanks for responding. I will wait until the current epoch is finished and the rewards should be in the rewards wallet the second it’s over, right?

No, if you setup delegation in epoch 4 then you don’t start earning until epoch 6. I did it on Monday, started earning (in theory at least) <1 hr ago.

I started at 10:30 am yesterday during epoch 3 so tomorrow at 2:15 I should see rewards if I have to skip one complete epoch before rewards start.

Yes you need to wait the current and next epoch. (so two days max)

And your pool needs to get selected to create a block :slight_smile:

I got exactly the same problem. First: unknown pool. Second: no staking pool appeared.

I did receive my rewards today and hopefully this will continue automatically every day now.
I am very happy with the annual percentage rate after some math. I am very happy I jumped through all the hoops to get to stake on the test net. This should give my totals a nice boost when main net begins next year.
I still don’t have a stake pool list on my wallet but as long as I’m receiving rewards I’m not going to mess with it. Maybe it will self repair with a software adjustment from IOHK, I hope.
We will see and if it corrects I will update this thread.


Did you receive your rewards today after the last epoch? I did receive mine even with an unknown stake pool.

Yes I also received my rewards today!
I reinstalled my testnet wallet and it has worked with no issues.
Rick from Cardano Effect did a video on his digitalfortress YouTube channel for a fix on not seeing pools. Here is the link https://youtu.be/5zpgQeHCGSA he runs the DIGI pool I stake to and is constantly putting out updates on his telegram.

1 Like

Mine was glitchy too, after I tried to send ada simultaneously using yoroi and daedalus at the same time. I think I broke cardano, but hey! Thats what the test net is all about. Breaking and fixing it for the long run

I think me not deleting the Balance Check Wallet for the snapshot may have been messing with the current test net wallet.
I tried what Rick’s video said but it didn’t work until I cleaned out the old wallet lines. As soon as that was done I had all 370 stake pools back on the wallet.
I’m glad you got me started on that because I would have been wondering what was wrong for a long time!
Cheers Wayne_Morgan!

Place your bets, ladies and gentlemen!!!

1 Like

yes, I just earned my first reward it is 0.05 % I also hope the reward is all to me no fees I will need to pay

Some pools charge fees, some don’t. I’m in one that does not charge fees.

I had no trouble delegating my three wallets, but now I got my first reward and it was zero. I have a fair bit of ADA, so I was expecting something. I will report back again on day 3.