Withdraw error

I am trying to send ADA out of Yoroi. The ADA is currently delegated. I am getting an error called
“Decryption Error”
Please help. I need to send this ADA ASAP. Thank you

perhaps yoroi issues… if it’s an emergency restore the wallet on adalite.io and send from there

You can’t change the world if you don’t master the simple things like saying “hello”. This is simple. Wallets should just work as reliably and confidentially 100% of the times. This is disappointing at so many levels. We should master saying “hello” before prentending to go out there and make it a better world.
Thx for the input

1 Like

@SycOps Nothing is perfect, nobody is perfect… There will always be some glitches… Nobody gave you/us an explicit guarantee there will be 0 problems running this software, or any software.

We must learn to accept that.

In case you paid for a service with an agreed SLA feel free to sue them in case they don’t deliver.

I know it can be frustrating but have faith in the team. We have options using multiple wallets, as Alex said try Adalite, Daedalus,… The wallet is an UI layer on top of the blockchain, you can use whatever you like.

Also, try searching for the address in https://cardanoscan.io just to verify there is no problem with the address itself. (ie typo)

There you have it. The error says “Decryption error”. I don’t think that’s on the UI side. And it’s still happening 24 hrs later. It’s ok for an elevator to go down in a skyscraper “because no one is perfect”. But 24 hrs later, the damn thing has to be working if it’s the “official” elevator of the skyscraper.
You are not going to convince me otherwise. I am a huge Cardano fan and would donate a kidney to Charles if he asked. However, Cardano does go to extreme levels with complexity in the big things. I admire that. They do however neglect the little things. That I can assure you.

When I pay for an elevator I get assurance in terms of a contract that it should not fail and that it has secondary security mechanisms to prevent a greater hazard.

Emurgo does not give any 100% guarantee there won’t be some minor bug within Yoroi.

I understand you are upset, but what I’m trying to say is, it’s all new technology, it’s free technology, there are no SLAs and service guarantee agreements. Many people spend their free time working on these technologies. I feel our expectations are too high sometimes. Let’s have faith in the engineers that they will resolve this issue.

I don’t know for sure, but it can be on UI side. For example if Yoroi is taking that BECH39 encoded address and trying to decode it in order to validate its payload prior to sending any transaction… I assume there are tons of other scenarios as well…

There are other official tools you could fall back to. Daedalus full node wallet and the command line interface. There are also unofficial ones as mentioned above, ie adalite.


Btw these are the Yoroi Github repositories where you can search/submit issues:

I have a high end laptop that cost me a few thousand dollars. It is hard wired to the internet and most of the time my Deadlous wallet fails to connect. I appreciate the advice but Yoroi is the official wallet for Cardano. My point still stands. It shouldn’t fail for that long. Going to other wallet means I have to access my seed phrase and restore. That’s not an easily accessible event or process.
It doesn’t even give you any explanation as to what the error is or how you could troubleshoot. See “the little things” that matter.

As for the current version I agree with that.

Anyway, my advice would be to file a Github issue for the error and an enhancement proposal regarding error descriptions.

This error shows up when you use a wrong spending password. Check that you are using a correct password and that your Caps Lock is of since passwords are case sensitive. Also, remember that your spending password is not the same as your pass phrase.


Thank you very much. That’s hard to believe I wrote the wrong password but just incase, I can restore the wallet with the seed phrase and assign a new password correct?

Thx again for the tip. I will look into it

Yes. After restoring the wallet you will be able to create a new spending password.

1 Like

I am grateful for Cardano and the community. It worked. I restored the wallet. Cardano has, and will always be awesome. I wish the error would have said “wrong password” instead of the confusing “decryption error”

Thx again.

1 Like

Love happy endings, my faith in ADA is restored. Great work team!!

I may have the same problem and getting a decryption error…is there a way to reset the spending password?

I wrote my spending password in a notebook but for some reason, I am getting this error message when I tried withdrawing my ADA and sending it to Binance. Please help. Thanks!

How to restore the wallet? Newbie here…thanks!

which wallet, yoroi?

go to add wallet (shelley era) → restore → use the 15 seed words for yoroi

1 Like

Thanks Got it…I will now check if I can now send my ADA to Binance. Hope this works now. This is a great community…glad I signed up.