Yoroi + Daedalus Testnet Wallet Issues

He guys,

  1. I have successfully installed Yoroi testnet extension on my Firefox browser.

I am browsing in incognito mode and have given permission to run in private mode.

The problem I have is that nothing happens when I click on the “continue” Button…

So I cannot pass step one…

  1. I wanted to give some feedback on the Daedalus testnet wallet too.

When the wallet was synced and I created the balance wallet successfully, I continued creating the rewards wallet.

When I tried to create my spending password, the wallet started syncing again. The syncing started at 94% and was DECREASING to 92%. When it reached 92% (so not 100%) I was back in the wallet and could to continue the steps. I could successfully complete all steps though.

Same thing happened here… Was writing down 15 words for the staking reward wallet I created in Daedaduls, when all of the sudden it jumped back to syncing (94%)… I restarted the node and it went straight back to the 15 recovery words and I could continue.

1 Like

Yes it went back to 94% like you said…(I mad a mistake stating it was back at 95%)

For those who have had this experience and have given up. Here is my solution for this platform:

Hardware: Surface Pro 3
OS: Windows 10

After installation it was stuck in “Starting Cardano node”, the orange button link that appeared after a minute was very helpful: https://iohk.zendesk.com/hc/en-us/articles/360035654533-Daedalus-Hangs-on-Starting-Cardano-Node-screen-Windows-

I followed the advice for the “Starting Cardano node”, but found that in the Environment variables there was already a statement “%SystemRoot%\System32\Wbem”. At first I ignored it not being sure about removing it and causing unexpected problems and so, just added the recommended statement “c:\windows\System32\Wbem”. After rebooting the computer and restarting the Daedulus Wallet, it still hung at the same point “Starting Cardano node”.

After frustrating several attempts by both rebooting the computer or restarting the Daedelus Testnet wallet (agreeing with Einstein: “sign of insanity is when repeating the same thing and expecting a different result”), I decided to brave it and go back into the Environment variables and deleted the “%SystemRoot%\System32\Wbem”, and then rebooted the computer. When I started the Daedelus wallet, it loaded straight into the create /restore screen.
However, it also behaved like those experiences above sync going backwards from 95% to 93%!!! It was fortunate the feedback on this Forum was there, I would have freakout!
So I closed the app and restarted it and it worked without further problems.
Conclusion: Smart move by the Project Teams to have this first snapshot! This would have been a disastrous Customer Experience if it had been on the mainnet. So a great opportunity to get the fixes. Otherwise, really straightforward.
Thanks Team…whats next??



How to force the node to sync when the node is not syncing but hanging.

  1. Select the icon: ‘Node is not syncing’ which will display a status screen
  2. In the section: ‘CARDANO NODE STATUS’, select the button:‘RESTART CARDANO NODE’. This will return to the initial screen and icon ‘Node is running’ will turn green and the networking syncing will start automatically to completion

Doesn’t always work… For me it seems to help a lot to run as administrator.

You may have not made a mistake as I watched mine go from 96%, to 95% then 94% at which point I restarted the wallet.

Following the restart, it allowed me in but displayed zero ADA, so I checked Daedalus through the Yoroi balance check testnet and all ADA was there.

Yoroi’s issue in Private Browsing is actually a bug in Firefox. You can see it here: https://bugzilla.mozilla.org/show_bug.cgi?id=781982

They say they are actively working to add storage functionality for private browsing in Firefox and they say they hope to have it completed by the end of the year.

1 Like

Is it normal that for installing the yoroi testnet version you don’t need to give the spending password? Only the recovery phrase?

Ah ok thanks Sebastien…Guess I’ll need to install chrome to fix this problem

Spending password is (as the word sort of gives away) for spending. You are not spending ADA from you Daedalus. I think the password is linked to your Daedalus installation and not the blockchain.

Let’s say you have some documents on an USB and you put them into a ZIP file. After that you put a password on the ZIP file. Then you can’t open it without the password.
Now if you use the same documents to make another ZIP file, you don’t need the password. The password is linked with the first ZIP file you created, not with the documents.

Not exactly the same, but hope you get the idea. :wink:


Hey thanks Josseh80, that’s clear. Just wanted to be sure it was safe.