Yoroi + Ledger Nano S will not let me make a Shelley era wallet

When following the procedures to make a hardware wallet in Yoroi on Chrome browser / Windows 10 pro, I get rerouted to the option to choose from Ledger Nano S or Nano X again after I had already exported my public key to Yoroi. Before exporting the key I had already selected Nano S. Ledger now wants to send the public key to open a Byron era wallet instead of Shelley. I had initially selected Shelley. I tried this procedure several times and the same problem occurs every time. I do have the latest software installed on my ledger and a brand new version of Yoroi. Any suggestions?



Can u try with mozilla firefox?


Thanks! I did try that already, but it did not help.

Ok, u can try also on adalite.io to connect ur ledger

Can I use Adalite for staking? Then I will try that.

Yes, u can; u will need the pool id

Great, then I suppose you solved my problem. Thank you.

1 Like

I am so glad you have posted this because this is exactly what’s happen with me right now.

It all worked out after all when I decided to just follow that next step, after all the steps I mentioned in my original post above: to send a public key for opening a Byron era wallet. When I did this the correct Shelley wallet was made in Yoroi. The Byron name on screen was the only thing that was wrong. I sent my first ADA to the wallet and it seems to be working fine now, including staking options.


Yea that’s exactly why I stopped, when I saw Bryon on the ledger screen, I thought something was wrong so I pulled out my ledger and restart then it all repeated so I stopped trying. Thanks for the update, I will try again!