Yoroi transaction suck at submitted

Yesterday I had sent 20 separate transactions from my Yoroi to Daedalus and only 8 have gone through. The other 12 are on my transaction page on Yoroi showing me the status as “Submitted”. It has been well over 24 hours and they have yet to come through. I have checked Cardanoscan on those transactions and it appears there is no transaction found. Have I just lost my ADA?

You can do “Resync Wallet” in “Settings” – “Wallet”. That should clean up pending/failed transactions and Yoroi should show the balance calculated without these transactions, again.

You cannot lose ADA by such things. If the transaction does not reach the blockchain, your ADA will not be moved out of your wallet. Your wallet is not in Yoroi, it consists of the history/transactions/balance recorded on the chain and your seed phrase (or hardware wallet) that is needed to sign transactions for them.

1 Like

nope, you will need to re-sync the wallet → settings → re-sync wallet

Cheers,

1 Like

The ADA has already been deducted from my wallet. If i resync - will I lose the ADA too?

Then u should have a transaction ID … did u checked the transaction ID on cardanoscan.io ? If the transaction is available on network then the transaction was processed, if not the it wasn’t and u should see the right balance after re-sync

The transaction ID takes me to the website Cardanoscan.io with a page that says “Transaction not found”. Should I assume that the transaction never actually went through?

If the transactions never got through, it’s just Yoroi’s guess at the balance and will be corrected on resyncing.

The real balance is the one according to the blockchain as shown on Cardanoscan.

1 Like

Then re-sync the wallet, the transactions weren’t processed due to network congestion

one more thing… when u check one address from yoroi on cardanoscan.io do u see the right balance?

I’ve just resynced my wallet and now all my ADA is gone. Its just showing my total rewards. It has also taken me out of the stake pool I was in.

What does it say in the transaction history? Are there outgoing transactions that explain it?

Be patient… it’s just the re-syncing process

Then, @Alexd1985 is most probably right, that it’s just the resyncing process. Mine is showing waiting indicators in the process, not zeros. But it is also running for 10 minutes or so up to now. Awfully slow, today.

I hope it puts me back into the stake pool I was in.

Go to receive, copy one address and check it on cardanoscan.io … the delegation is not affected, it’s just a process, interogating the db since shelley started…

Stake pool delegation is also stored on the chain.

Yoroi (and other wallet apps) are just interfaces to control your wallet.

As long as you have your seed phrase, it does not matter at all if they lose their data, get broken, get uninstalled or whatever. You can always choose another one or reinstall the same one.

In fact, I would recomend to carefully choose two to three different wallet apps and keep the wallets imported/restored/synced in all of them. If one wallet app has problems, you can always go to another one and view the state and do transactions from there.

Do you mean the seed phrase to my Yoroi wallet?

Yes, exactly that one.

With that all wallet apps can view and control the wallet. So, it’s not really a Yoroi wallet, more a Cardano wallet.

I’ve tried a longer explanation here a few days ago:

1 Like

So I think the resync has just finished. Its showing me the correct total ADA - the “submitted” transactions are now gone leaving only the completed transactions. Thank you everyone for the help/support. Sorry for the newbie questions - as this is the first time I’ve actually had to resync any wallet.

Much love for this community.

2 Likes

Glad u solved it :beers:

1 Like