Pool retirement, pledge and deposit

It’s not clear for me if u need to add pool deposit again

I just removed it…but seems to not work…but If I add it again and they subtract it again I will have paid it twice, so no good…

Maybe u will pay again but u will receive the first registration back as reward… I don’t know the process, but u can try

I have submitted it 3 times…all seems good…it is received but the message doesnt change…

I don’t know, wait for the epoch transition

Ok, now it is not showing the message in adapools.org but it is still not appearing in pooltool.io…isn’t it weird?


check the metadata

1 Like

Yeah, seems that the hash is not correct, but I didn’t change anything so the hash should be the same. Anyway, really good to know, thank you!

1 Like

And also check the topology updater script for the relay… it must run 1/hour

It must run one hour? What do you mean? After or before changing the servers IPs?

all the time… once/hour

Do u have IN peers on relay?

1 Like

I did it, the BP mode is syncing…so I guess it lost the old relay node and the other one did not appear yet…as I updated the topology json and also run the topology updater script but seems the BP is not able to get the relay node

Also in adapools.org still the old relay is showing up…

I have the relay running, I updated the mainnet-topology.json to the BP I already had IP and run the script to update the topology…do i have to do something else?

what IP do u have inside the topology file of the Producer?
also on producer and on relay if u will type ifconfig… what IPv4 it shows? the private IP or the public IP?

1 Like

I have the IP of the new relay and in the relay I have the IP of the old producer node, so seems it should work…and in both cases eth0 interface shows the public IP…

I restarted the nodes and now they are both in starting mode…should I stop and start them again?

  • inside the topology file of the producer you should have the relay IP: port 6000
    also in firewall u should have a rule to accept the new relay IP

  • inside the topology updater script from relay you should have the new IP of Producer + port (which u see with ifconfig)

  • starting will take more time if you used sudo systemctl restart cnode
    u can also use sudo systemctl stop cnode and sudo systemctl start cnode

  • also for the producer you can type
    journalctl -e -f -u cnode and check the last lines for errors

1 Like

Time did its effect and now all seems working well :slight_smile:
Thank you for your support, is much appreciated!

Now I have to convert the other node into the new BP node…I will copy/paste all the keys, certs and metadata file from the old node to the new node. Is that okay? Then update the IP of the new BP for the topology…and that would be all?

correct, all u have to do is to move the files to the new BP, if u have issues let me know

1 Like

but still few errors on pool.vet and also the pool is not visible yet in pooltool.io
there is something with the hash of the metadata, did u modify it?


1 Like

True, I will work on it…I did not modify it so that is weird…anyway, I will just re-compute the hash and sign the certificate with the new hash, I guess it should be solved…thanks mate, I really appreciate your help!

Seems the issue with the certificate is solved now, I submitted a transaction with the new hash info, I still do not understand why it changed but seems it is solved now, can you confirm it please? Thank you!

Going to proceed with the new BP…hope to not have many issues :rofl: