For those still on testnet: we can collaborate here

Hi all,

I hope all is well. As the title says: is there an equivalent to pooltool.io for testnet? Can someone tell me if they can see my testnet pool:

POOL ID: 997a9aad908618a7960867586023c66bbd27af1304a19f63512fbe4d

I can query the ledger and find it, I just cannot find it in Daedalus (testnet version). If anyone can find my pool, could you tell me what ticker you see?

Cheers,

A

just in case:

cardano-cli shelley stake-pool registration-certificate
–cold-verification-key-file cold.vkey
–vrf-verification-key-file vrf.vkey
–pool-pledge 1000000000
–pool-cost 340000000
–pool-margin 0.05
–pool-reward-account-verification-key-file stake_t.vkey
–pool-owner-stake-verification-key-file stake_t.vkey
–testnet-magic 1097911063
–pool-relay-ipv4 x.x.x.x
–pool-relay-port xxxx
–metadata-url https://bit.ly/2GbsAgR
–metadata-hash 27342d9bb3efe80f713ee41bd6e0645a7efc55c9f648cb8638aaf6475a0e7df7
–out-file pool-registration.cert

is the code I used for the certificate generation. I then followed with payment of deposit/fees, signed and submitted. None of the steps produced errors as far as I could tell.

Cheers,

A

Sorry, not aware of any pooltool testnet version.

Stupid question. For the relay IPs, did you put in your actual IP address and port number when submitting the registration or did you submit with x’s?

I put the relay’s address and port. This is a aws instance and the core node is only connected to it. As far as I can tell that side of things is working, and all is in sync with the chain.

The next step I would like to achieve is give that address and port to the community so as to see if people can hack my node.

For now I just post x’s in an attempt to get into good practice for mainnet. :roll_eyes:

1 Like

I’m just not sure why the pool doesn’t show in Daedalus :thinking:

You did try to query the ledger on your connected node?
After one block (at current chain density) it should be registered:

cardano-cli shelley query ledger-state --testnet-magic 1097911063 | grep "publicKey" | grep "997a9aad908618a7960867586023c66bbd27af1304a19f63512fbe4d")

Visibility on daedalus always depends on when the wallet fetches a new set of pools…

Same problem here…registered the pool, have the pool ID, but this command -->
cardano-cli shelley query ledger-state --testnet-magic 1097911063 | grep publicKey | grep <my.poolId> yields nothing…it hangs for a bit but then just comes back with new empty line CLI prompt.

However, the following command,

cardano-cli shelley query ledger-state --testnet-magic 1097911063
| jq ‘._delegationState._pstate._pParams.<my.poolid>’

at least returns “null” statement…it’s still nothing, but at least it’s telling me it’s nothing…lol

At least you got yours to show on testnet ledger. Which online source (website) did you use to query the testnet ledger?? I can’t find a “pooltool” for testnet, or did you just mean by entering the command

cardano-cli shelley query ledger-state --testnet-magic 1097911063 | grep publicKey | grep pool1hcefh0cwur6n6x0nk2qgvythnfyu0h6r7vc2sq67h8u9x8z2cla

instead of using online source to query the testnet ledger?

@JT_Cazorla

Thank you for your input. I have since retired the pool mentioned in this thread and spun a new one (still in testnet). So here are my thoughts:

  • I think by now everyone agrees there is no “pool tool” equivalent for testnet;

  • I can query the ledger with the command line and find my pool ID;

  • my second attempt also immediately appeared in Daedalus (testnet version).

Now, in my second attempt (which you may be able to see live yourself: the ticker is ADRE2), two main things were done differently (this makes it difficult to tease apart which one was the problem or if both were):

  • since cardano-node 1.19.0 the startKESperiod must be currentKESperiod - 1. For my first pool I did not know and therefore did not do this, despite having 1.19.0;

  • the url to my metadata was a long mess for the first pool. Then I tried to rectify that, by submitting the registration again (which created even more issues). The second time, my url for the metadata was nice and neat (I used bitly from the start, to shorten a github repository address).

It has also been suggested to me by several people that it is good practice to check the hash of the metadata after downloading it from the url you control, to make sure it matches what you submit to the chain.

I hope this helps, let me know how you go and I’ll do my best to help.

Cheers,

A

Thanks! I didn’t know about

My first attempt went ok with the url. I was thinking to myself, “they’re crazy”. My url is 67 characters long by default generated on github, so how am I supposed to get it down to at most 65? So what I did is I changed and shortened my username to get it to work, but then when I went over stakepool course part dealing with url, I realized how short Carlos’s url was, so I typed in ‘git.io’ which I saw in his shortened url as part of the url name and was able to find “url shortener” tool on git.io and used that to make short url.

I was using a program called timeshift in linux to back up my files so I could return to an earlier working version and start from there instead of installing node from scratch. Well, in my haste to back up one of my sessions, I think I cut the process short of backing up all the files, so when I reinstalled that backup - the one I had worked on the longest - I would occasionally get “ubuntu system problem” messages pop up on my GUI/desktop, which it didn’t have before the backup. So I did a fresh install of Ubuntu from scratch and restarted the course.

Some notes for others reading this thread: if you use github to create your url, and shorten that with git.io, or some other ‘url shortener’, your url will take others to your github page. If you want a ‘website’ looking page with just your ‘pool-related info’ click on the “raw” button to the right, that will generate an url that takes you to a normal looking webpage, then you can shorten that url using git.io. Also, changing the filename of your url has no effect on the hash value of the file…the hashing function used in this instance is only concerned with the contents of the file, not the name of the file itself.

Anyway, Adrem, the biggest problem I’ve had on my second install is that I was accidentally generating errors by having an extra space (having been entered manually accidentally) at the end of a line in my in files to build transactions.

If you use vim and type vim tx.build, for example, it takes you into the file for editing, linux uses special characters which have more than one meaning, like $, ‘space bar to create a single space’, #, etc.
To tell linux you mean to use a regular character reserved for special status as a regular character only, you use the backslash \ before entering that special character of which ‘space bar’ or ‘single blank space’ happens to be a “special character”. Linux sees \‘single space’ and ‘single space’ differently, the latter being a special character and the former just a regular “press of the space bar” or single space. On my edits I discovered that either my file was corrupt or I had corrupted my file because using vim to enter a file to edit it:e.g., ‘vim filename’ will take you into file ‘filename’ to edit it. The files we work on usually look like this:

line one \
line two \

last line

Say represents your cursor position. If you use vim to edit your file and move your cursor through each line it will take you to the last visible character in each line.

So, for each line with backslash, you should see the furthest right you can go is…

line k [\]

where the cursor sits on top of the \ symbol. Check each line by scrolling to the end of the line, if you can go past the end of the line with the cursor, e.g., line k \ then this will generate error(s) when you try to copy, paste and ‘enter’ to run command or run the command through your file as a script by giving it user-executable permissions.
If you notice your command is being split up when pasted, only a few of the last line get processed when you run the command even though you copied all lines, or one of your flags; e.g., --ttl 23442 cannot be found error, then this likely means you have an extra space at the end of one of your lines. Go through each line deleting any extra space at the end of each line and also deleting any extra lines at the bottom of your command and especially deleting any extra lines in the middle of your file.

last line

~
~
~
The above file contains an extra blank line…this blank line appears in vim by not having a tilda ~ symbol for that line;i.e., if you see ~ symbol that means no blanks lines - the end of the file has been reached at the first ~. In this case, you can see there is an extra line after ‘last line’, so get rid of all such “extra lines” in your files so it looks like this…

last line
~
~
~
~

Extra spaces and lines is where some of my errors came from that were hard to track down. I know extra spaces created errors, but I’m not so sure of extra lines, but I got rid of them anyway because extra lines have a bunch of spaces which linux sees as special characters, which means an extra line might generate errors even though extra line(s) appear after the last line of your command lines.

I still have to set up ufw on my relay and bp. I don’t know if my SPO is working…my block producer is not pulling blocks from IOHK’s relays in LiveView mode. I’ve used internal IPs for my start-up scripts for relay and core as well as for topology files for the relay and core to talk to one another, but not for the IOHK relays in the topology file of the relay…still no blocks showing up. At what point should they show up, do you know? At what point of the process did you get blocks to show up in LiveView if you used that? Mine is always showing 0 blocks. My guess is IOHK’s relays might have trouble finding my core node because my relay host file is using internal IP, but when my relay sends messages to IOHK’s relays even though it’s using an internal IP, IOHK should see external IP with the correct port number 3001 to the relay since routers translate internal IPs to external ones when they go out on the web, so I’m hoping their servers know to respond back on my public IP with the correct port number 3001, so my relay can forward blocks internally to my core node. I think the problem is with my relay’s internal host file. I’ll try changing that.

@JT_Cazorla

Glad my first suggestion helped. For the rest of your reply:

  • I cannot make any informed comments on the editing of text files, but so far have had no issues on that side other than the occasional typo or indent (I use gedit or nano);

  • for your nodes not syncing (blocks at 0 as you say above):

A) are you using local machine(s) for your relay and BP?
B) is the relay syncing with the chain?
C) as far as I understand LiveView or SimpleView should in no way impact how your nodes sync. Which one you use is just a preference and might determine how you query some metrics (not sure yet about this last bit, haven’t finished experimenting yet).

Once I know more about your set up and topologies I can try to pin down the issue with your nodes not syncing. Please let me know if I can be of further help.

Cheers A

1 Like

Both relay and core slot tips are synced with blockchain.
Yes, both machines are laptops at home (local).
Yes, LiveView and SimpleView are just different types of GUI interfaces to what’s going on between subbed relays, your relay and core.
When I’m on LiveView it shows I’m not processing any blocks. Is this because I’m not slot leader or because I’m supposed to process blocks even if I’m not slot leader and something isn’t working?

Thanks for your help.

I got the firewalls on both relay and node working.

Don’t know if this is normal, but my relay shows up in my core node window by itself, and my core node shows up in my relay window along with two IOHK relays (I set IOHK relay valency to 2, so that makes sense), but my core node . I gues it does make sense because my core .10 is using port 3001 to talk to relay so it shows up in port 3001 windows, and similarly, my relay .11 is using port 3000 to communicate with my core, so it makes sense for it to show up in port 3000 window I guess.

192.168.1.10 is my core, and 192.168.1.11 is my relay. I thought the host file is for setting up the the machine you’re working on, not for the one you want to connect to, like the topology file.

Anyway, my In flight: Reqs Blocks and Bytes are amost always 0. Once in a blue moon they flash very, very briefly with numbers, but too short lived for me to read it.

Last night I was able to register my stake pool on the blockchain (testnet). I can see the stake pool ID when querying the blockchain for it, but I cannot confirm that it’s registered on the blockchain…the command doesn’t give back any results, so maybe this is why my node isn’t pulling blocks yet. It has been registered, but maybe I have to wait some time, like an epoch for it to show up? You know how a number of things don’t change in Cardano until one or more epochs pass by, so maybe I’m having same issue. You think that’s possible? At what point of the installation process did you actually start pulling blocks from others’ relays?

Ok, I had misunderstood your question. As far as I could tell from my setting up, the requests were high in the initial phase, when the nodes (mine) were in the process of syncing (with the IOHK ones).

Please note I am not sure that I am correct when I say that the in flight requests should quiet down once you are at the tip. I will invite others to this topic to confirm. I have now invited @ADAfrog, he has been of great help and may be able to shed light on this.

Also, yes, your core and relay look as they should (3 peers for relay, 1 for core). In the absence of a topology updater for testnet, I think you and I can share topologies, so as I can add your relay to mine and viceversa. I will post more info here when I get time off work tonight.

As to the last bit of your post: are you able to see your pool in Daedalus?

Cheers A

1 Like

I think that’s why my pool doesn’t work - it’s registered but doesn’t show up when querying the blockchain because the pool ID starts off pool…3kd89c9fdkdeld. Yours doesn’t. What did you do differently to get a normal pool ID?

In your query of the pool ID, you have to specify you want the output to be in HEX format. Add:

–output-format hex

At the bottom of your pool ID query command

1 Like

No, I haven’t installed daedalus testnet walet.

Yeah, it worked. I coverted format to hex, and queried the blockchain. The testnet pool is on the ledger.

1 Like

Can you install Daedalus testnet? It would be great to have another (active) pool operator to work with on testnet.

So far I have no other means to “see” my pool outside of the command line other than Daedalus.

Daedalus works for that purpose and you can also delegate tADA to your own pool for further testing.

I’ll post topologies and other info later.

Sure! I might have a problem though…when I query the stake.address, the old pool… address format comes up…don’t know if that will work on testnet. I can try at least. I would like to change the format to hex if it doesn’t require redoing the stake pool registration cert all over again. I’ll download the wallet when I find it and message you back on this thread when it’s up and running.

Ok, cool. I think the format of your address will be fine. I never had problems with that.

If you can see your pool on Daedalus once it has synced, just get some ADA from the faucet to a new Daedalus wallet and delegate to your pool. In my case it worked.

Next step I want to do is check the number of delegators on the back end.

Talk soon,

A

1 Like