No "In" peers on Producer Node

Hello all!

I am getting so close to a fully functioning stakepool that I can almost taste it! Having nothing staked currently I understand that I won’t be minting blocks anytime soon, but I’m excited to complete this project. I still have a handful of questions left and I’m unsure if I should just throw them all into one thread or spread them out over several. For the time being, I will ask about different topics in separate threads (I hope that isn’t spamming).

Right now my pool is registered (Quantum Energy Tokens “QET”) and can be seen from,, and I don’t know if there is any other locations that it MUST be located. Both the producer and relay nodes appear to be running and processing TX (not Mempool TX/Bytes for some reason) but the producer node appears to have no “In” peers and I’m not sure what is missing. I have attached gLive pictures from both nodes.



Once again any and all thoughts or opinions are welcome!


I think this is related, once you have a working topologyUpdater there will be incoming peers to your relay

1 Like

Now that the Crontab issue is resolved I still have no “in” peers. Can someone please tell me where that data point draws its information from?

Check the ports 6000 for both node… if is open

From ur relay try

telnet Producer-IP Producer-port
U should be open; if yes check if u added the correct Producer IP and port in topology push push script

1 Like

(Image removed)

I dont have a “push script” but the same port number and IP are in my "“”

Understand… so if u run the script… u see the Producer IP to OUT peers in the Relay?

1 Like

After running the gLive script My block producer IP and Port are number one in the list-

Ok, so now… do u have IN peers in the Producer? Should be ur Relay

1 Like

Still no in peers, but the out has the public IP twice, once with my chosen port and once with something seemingly random after. Should I restart the producer node or even the pc itself?


Can u show me the relay push script? Cover the IP or port

1 Like

Is the push script the topologyUpdater?
(Image removed)

Env file (the cnode port is the port I use for my relay)

ok, you can restart the relay, and now, I see u have 6 OUT peers on your producer… you should have only the relay to OUT/IN peers

for the Producer, u don’t need to run topology updater script. only to add the relay ip + port in topology file

1 Like

This is my producer’s mainnet-topology.json. I don’t think I ran the topology updater on the producer, but it is possible, should I restart it as well?? What should I do to remove the additional unneeded peers on my producer?

(image removed)

but, both Producer and Relay has the same IP?

1 Like

correct, two physical machines in the same building on the same network

restart both nodes and check again

1 Like

Restarting both machines now. This will take some time.

1 Like

but… if u have the nodes on 2 physical machines on the same network.

why u don’t use the private addresses to connect the nodes between them
and use public IP for the relay only ?
also I think u will need NAT on your local router for the Relay port

The choice between public and private IP addresses was not something that was clear to me so I chose public, but I can change the addresses on both. Will the nodes not function correctly without the NAT?