Nami Wallet Transaction Failed

Hi, I have a Nami wallet, and it shows my current balance but every time I try to do any transaction is says “transaction failed”. Please help. Thank you

4 Likes

When does it fail? After you give your password? Are you sure that the password is correct?

You should have a 24 word seed phrase. With that you can restore the wallet anywhere (and choose a new password).

You could try it with Nami in another browser or browser profile. Or you can try it in another wallet app like ccvault.io or adalite.io.

It happens after I input the password, I am 100 sure the password is correct. I restored the wallet to a different browser the same issue is there as well. This all happened after I tried putting a collateral and then removing the collateral on the Nami wallet I don’t know if it has to do anything with that. Also I did a search on Cardanoscan.io and my wallet shows as inactive.

4 Likes

Hi,

I am also not able to buy NFT from cnft USING nami.i AM GETTING EOOR LIKE INVALID COLLATERAL EVEN AFTER ADDING COLLATERAL AND I AM NOT ABLE TO TRANSFER ADA OUT OF NAMI NOW. KINDLY HELP

1 Like

You can restore the wallet using the recovery words in another wallet software like adalite.io or ccvault.io and transfer your ADA, if Nami is causing issues.

With Nami wallet if you are using smart contracts to buy/ swap or transfer you need to have minimum 2.5 ADA free besides your 5 ADA collateral. If there isn’t enough ADA to lock into the contract with the transfer amount + fees then transactions will fail. So, for example if you are trying to isnta-buy something that is 10 ADA you may need minimum balance of 12.5 ADA (that’s mostly for CNFT).

You can also quickly check how much of your ADA is locked by Nami if you hover above info sign next to your balance.
info
If you feel that you have more then enough ADA and it’s still stuck just recover your wallet with Yoroi and use SEND ALL ASSETS to a different wallet. That will send everything from Nami address to your other/new wallet. (Don’t forget to remove collateral and cancel any pending smart contracts so you get deposit and assets back :smiley:)

1 Like

ya wtf. me too. it says its inactive as well. nami isn’t working out so im trying to remove my ada from the wallet and it just keeps failing the transaction… pissing me off

4 Likes

Exact same issue, need to transfer my funds ASAP but I’m not able to! Please fix this.

We are not the Nami support, we are the Cardano forum.

That being said:

2 Likes

I keep getting this issue and I have now realised it is because I am using Nami on two computers. If I add it on one, it works fine. If I go to computer number 2, it asks me to add it, then works. It continues to work until I go back to comp 1 and it asks for the collateral again, I have no idea if I am getting these 5 ada back each time, but I try to stay on one now, That may, or may not help…

If I understood that correctly:
https://docs.cardano.org/plutus/collateral-mechanism

Collateral are just special UTxOs that stay in your wallet, but are given to transactions with smart constracts. If the contract is okay they come out of it again and are not taken. Only if the contract runs into something invalid, the collateral is taken as compensation.

Now, Nami seems to try to reduce risk by transferring 5 of your ADA and not more to one UTxO, so that not more can be taken. That would be one transaction costing a small transaction fee, but the collateral obviously stays in your wallet.

The other Nami instance cannot know, which UTxO the first instance chose as this special UTxO for collateral. It’s only a Nami thing and not encoded in any way on the blockchain. So the other also offers to do that, does that.

But why do they forget it again? Can you look in your transaction history? Perhaps, they always use the 5 ADA collateral UTxO of the other one as input when setting up their own. And then it can’t be available anymore, when returning to the other. (Using other wallet apps in between would also risk that this 5-ADA-Collateral-UTxO is used in a transaction and is not available next time.)

In the long run, this will cost a lot of transaction fees. I would perhaps only use one of the two for smart constracts and not set a collateral at the other one. And perhaps file a bug with Nami? They don’t seem to have thought usage with multiple computers through.

@CardanoMan. Did your issue ever resolve? I have the same issue and am wondering if I just need to wait a period of time or will need to creat a new account within Nami and see if I can transfer funds.

Have the same issue cannot set collateral atm, might be due to network load i assume?

1 Like

im having the same issue cant set collateral but have more then enough funds just keeps saying transaction failed. To much network load?

1 Like

Same here as well. Adding collateral, transaction immediately fails. Checked everything I could, but short of removing the extension and readding, it isn’t working. EDIT: Actually, I cannot send anything from it either but was able to send a test amount to it…

another fkg SCAM is NAMI i deposited 1000$ and now it shows me
mempool full namiwallet
transaction is failed

and my fkg bad chance is i have 23 word instead of 24 word and it’s because of their fkkk recheck issue CARDANO you have to answer because you introduced in your DEX exchage website as a first wallet

Hi there!

I had this issue and was able to find a solution and I think I have a decent idea of what’s causing it as well.

Nami gives a warning when you sign up that it doesn’t work great with importing other cardano based wallets and prefers you create a new one with them. So when my transaction failed, I wondered if the Yoroi wallet that I had separately on Google Chrome was interfering somehow. I restored my Nami wallet using the key phrase on Microsoft Edge and I was able to send my ADA. To clarify, I restored with Nami, by clicking the import button and using the key phrase to import my Nami wallet that was on Chrome. I now use Nami just fine with Edge and all my assets transferred.

Not 100% sure if the problem is using two ADA wallets on the same browser or not, but that is my hunch given that this worked. Hope it works for you too!

Hello Everyone,

I too am experiencing the same issue. However, I believe it is a congestion issue. As people are loading the Nami servers because it is one of two wallets used for SundaeSwap at the moment. Thus the processing is slow. Perhaps that addresses are deactivated after the first swap attempt to prevent subsequence swaps with no real backing on the back end. SundaeSwap anticipated this sort of behavior in the beginning.

For example, I placed a swap order and the request took an hour to reflect in the front end (UI). Therefore, I think it is extreme latency.

Also having this exact same issue. Definitely have the right password.

This is supposedly Cardano’s premier AMM Dex?? Oh boy! Not good fellas. :-/

im having the same problem , did you sort it out?