Download Daedalus Rewards and start earning real ada rewards

Last week, we successfully spun up the the Incentivized Testnet network and opened it up for stake pools to join and connect. It’s only been three days but we are thrilled to report that we already have over 300 established stake pools, ready for you to delegate to!

For anyone who participated in the 29th November snapshot, we invite you to download the dedicated testnet Daedalus Rewards wallet. You’ll be able to use this wallet to restore your testnet ada balance, browse through all the available stake pools and delegate your ada to start earning real ada rewards! Yoroi’s testnet wallet will follow shortly and expected to be available later this week.

Download the Daedalus Rewards on the official Incentivized Testnet website here.

Please remember that this is a testnet, designed to help us improve the platform and test the Cardano protocols on the way to the Shelley mainnet release. We anticipate there may be outstanding bugs or minor issues. Note that there will also be subsequent releases of Daedalus Rewards with enhanced usability, added features and functionalities. Your feedback is invaluable to us - if you experience any issues or anomalies with this early wallet release, please submit a support ticket directly through the help menu in Daedalus or log them at the IOHK Support Portal.

And for those of you interested in running a stake pool, it’s not too late! Please check out the newest documentation that lays out all the necessary steps for getting your pool running and registered on the Incentivized Testnet. We have also created a multi-part video series that goes through this process.


Great job sticking to the schedule and delivering a quality product. Bravo!

Here we go thanks!

1 Like

why is it that on the landing page ( there is no link to download Daedalus Rewards? I understand that it just dropped - but it’s kinda an obvious thing that one should naturally came to expect to find there. I mean i even went to the Daedalus website ( to check if it was there but nothing, not even a link… ¯_(ツ)_/¯

btw the link in the telegram group isn’t hyperlinked, i think because the line is broken right after the https://

and thanks @maki.mukai for posting this :bowing_man:

UPDATE: it’s now been added as a banner at the top, would help if it was in the body as well though.

great job, I just delegate on 3 differents pools…

Try this out
First try firewall blocked it saying wrong Signature.
Trying has i’m writing nervous so many scammers!

We want Yoroi! :slight_smile:

Yoroi Staking Wallet is coming very soon.

Thanks IOHK and team!
All good here. Downloaded, Installed, Wallets Created, Ada Staked.
Would love a bit more discussion about Pool performance and what all the figures mean etc. What is the incentive to stake with anyone but the number 1?
I’ll start a different thread.
Cheers All!

Aaaand my node is not responding. Haven’t been able to open the new wallet at all. Windows 10…

Wholey Dooley I’m in! Lessgo

1 Like

Im still getting the node not responding. Will try again tomorrow when its hopefully less congested.

my daedalus is not connecting…

Yeah I reinstalled then just kept trying. Finally connected

Hi, I can connect but I was unable to verify my checksum. When entering it in Terminal on my Mac it says command not found. How important is it? I followed the official link. Thank you.

Can you confirm the command you used?

When you click “Verify Checksum” it should bring up a pop-up with the instructions. Please also make sure you’re looking at the right instructions for the operating system you’re using. Thanks!

Hi, I tried both methods that come up with the pop up. This has always worked for me in the past so I have not entered in my 12 word seed until I get this sorted. Thank you.

Hi @Brad_Z

I just tested the checksum verification with both Win and Mac, and got a successful result on both.

If you can make sure you’re downloading the installer files from:

And if you’re still not able to verify checksum, I’m not sure what it can be. So please log a support ticket with the Support Portal:


So we’re a day into the launch of the Shelley Incentivized Testnet, and here’s a quick update. The network has been seeing unprecedented levels of activity, and while the network has been intensively tested and iterated over the past few months, the additional load has thrown up a number of edge-case issues affecting network performance as it scales. Though its caused some issues, its great to see so many people trying to get involved with the testnet!

Today, we’ve been working on a number of network optimizations and bug fixes (with the release of two new node updates) to improve network stability. With these new releases, the user experience when syncing wallets will also improve. So anyone experiencing syncing or network connection issues, please bear with us. Thanks for joining us in testing Shelley!